aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Flat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-File-Flat/Makefile')
-rw-r--r--devel/p5-File-Flat/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-File-Flat/Makefile b/devel/p5-File-Flat/Makefile
new file mode 100644
index 000000000000..3c3be5cf4362
--- /dev/null
+++ b/devel/p5-File-Flat/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: File-Flat
+# Date created: 11 December 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Flat
+PORTVERSION= 0.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Implements a flat filesystem
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/Class/Autouse.pm:${PORTSDIR}/devel/p5-Class-Autouse \
+ ${SITE_PERL}/File/Copy.pm:${PORTSDIR}/devel/p5-File-Tools \
+ ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
+ ${SITE_PERL}/File/Remove.pm:${PORTSDIR}/devel/p5-File-Remove \
+ ${SITE_PERL}/File/NCopy.pm:${PORTSDIR}/devel/p5-File-NCopy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Flat.3
+
+.include <bsd.port.mk>