aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-Flat
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-File-Flat')
-rw-r--r--devel/p5-File-Flat/Makefile30
-rw-r--r--devel/p5-File-Flat/distinfo1
-rw-r--r--devel/p5-File-Flat/pkg-descr12
-rw-r--r--devel/p5-File-Flat/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-File-Flat/Makefile b/devel/p5-File-Flat/Makefile
new file mode 100644
index 000000000000..3c3be5cf4362
--- /dev/null
+++ b/devel/p5-File-Flat/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: File-Flat
+# Date created: 11 December 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Flat
+PORTVERSION= 0.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Implements a flat filesystem
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/Class/Autouse.pm:${PORTSDIR}/devel/p5-Class-Autouse \
+ ${SITE_PERL}/File/Copy.pm:${PORTSDIR}/devel/p5-File-Tools \
+ ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
+ ${SITE_PERL}/File/Remove.pm:${PORTSDIR}/devel/p5-File-Remove \
+ ${SITE_PERL}/File/NCopy.pm:${PORTSDIR}/devel/p5-File-NCopy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Flat.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Flat/distinfo b/devel/p5-File-Flat/distinfo
new file mode 100644
index 000000000000..59a5555af18c
--- /dev/null
+++ b/devel/p5-File-Flat/distinfo
@@ -0,0 +1 @@
+MD5 (File-Flat-0.8.tar.gz) = b36ea287f9bddf7d07be875b78203c29
diff --git a/devel/p5-File-Flat/pkg-descr b/devel/p5-File-Flat/pkg-descr
new file mode 100644
index 000000000000..04a92c137905
--- /dev/null
+++ b/devel/p5-File-Flat/pkg-descr
@@ -0,0 +1,12 @@
+File::Flat implements a flat filesystem. A flat filesystem is a
+filesystem in which directories do not exist. It provides an
+abstraction over any normal filesystem which makes it appear as if
+directories do not exist. In effect, it will automatically create
+directories as needed. This is create for things like install scripts
+and such, as you never need to worry about the existance of directories,
+just write to a file, no matter where it is.
+
+WWW: http://search.cpan.org/dist/File-Flat/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/devel/p5-File-Flat/pkg-plist b/devel/p5-File-Flat/pkg-plist
new file mode 100644
index 000000000000..70a2f731a472
--- /dev/null
+++ b/devel/p5-File-Flat/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Flat/.packlist
+%%SITE_PERL%%/File/Flat.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Flat
+@unexec rmdir %D/%%SITE_PERL%%/File 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/File 2>/dev/null || true