aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Glib-Object-Introspection/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Glib-Object-Introspection/Makefile')
-rw-r--r--devel/p5-Glib-Object-Introspection/Makefile28
1 files changed, 20 insertions, 8 deletions
diff --git a/devel/p5-Glib-Object-Introspection/Makefile b/devel/p5-Glib-Object-Introspection/Makefile
index d40cf76561b1..6abcd6682e02 100644
--- a/devel/p5-Glib-Object-Introspection/Makefile
+++ b/devel/p5-Glib-Object-Introspection/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: p5-Glib-Object-Introspection
-# Date created: 2011-10-15
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Glib-Object-Introspection
-PORTVERSION= 0.010
+PORTVERSION= 0.014
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -19,13 +15,29 @@ LICENSE= LGPL21
BUILD_DEPENDS= gobject-introspection>=0.10.0:${PORTSDIR}/devel/gobject-introspection \
p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
- p5-Glib2>=1.240:${PORTSDIR}/devel/p5-Glib2
+ p5-Glib2>=1.270:${PORTSDIR}/devel/p5-Glib2
+LIB_DEPENDS= ffi:${PORTSDIR}/devel/libffi
RUN_DEPENDS= gobject-introspection>=0.10.0:${PORTSDIR}/devel/gobject-introspection \
- p5-Glib2>=1.240:${PORTSDIR}/devel/p5-Glib2
+ p5-Glib2>=1.270:${PORTSDIR}/devel/p5-Glib2
TEST_DEPENDS= p5-Cairo-GObject>=0:${PORTSDIR}/devel/p5-Cairo-GObject
+OPTIONS_DEFINE= TEST
+
PERL_CONFIGURE= yes
MAN3= Glib::Object::Introspection.3
+.include <bsd.port.options.mk>
+
+# Glib::Object::Introspection requires cairo, gio-fam-backend and glib20 to build
+# test libraries during build phase, therefore we add them to BUILD_DEPENDS.
+.if ${PORT_OPTIONS:MTEST}
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/cairo.pc:${PORTSDIR}/graphics/cairo \
+ ${LOCALBASE}/libdata/pkgconfig/gio-2.0.pc:${PORTSDIR}/devel/gio-fam-backend \
+ ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc:${PORTSDIR}/devel/glib20
+.endif
+
+regression-test test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} test
+
.include <bsd.port.mk>