aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-List-UtilsBy
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-List-UtilsBy')
-rw-r--r--devel/p5-List-UtilsBy/Makefile21
-rw-r--r--devel/p5-List-UtilsBy/distinfo2
-rw-r--r--devel/p5-List-UtilsBy/pkg-descr10
-rw-r--r--devel/p5-List-UtilsBy/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-List-UtilsBy/Makefile b/devel/p5-List-UtilsBy/Makefile
new file mode 100644
index 000000000000..055bcb9bb121
--- /dev/null
+++ b/devel/p5-List-UtilsBy/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: List::UtilsBy
+# Date created: 25 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= List-UtilsBy
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for higher-order list utility functions
+
+PERL_CONFIGURE= yes
+
+MAN3= List::UtilsBy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-List-UtilsBy/distinfo b/devel/p5-List-UtilsBy/distinfo
new file mode 100644
index 000000000000..3e5954fa9b9d
--- /dev/null
+++ b/devel/p5-List-UtilsBy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (List-UtilsBy-0.06.tar.gz) = c7a24e898cc8559140706d6756113959026ca88972d06906976869bfef16e3c7
+SIZE (List-UtilsBy-0.06.tar.gz) = 18478
diff --git a/devel/p5-List-UtilsBy/pkg-descr b/devel/p5-List-UtilsBy/pkg-descr
new file mode 100644
index 000000000000..2788949a2907
--- /dev/null
+++ b/devel/p5-List-UtilsBy/pkg-descr
@@ -0,0 +1,10 @@
+This module provides a number of list utility functions, all of which
+take an initial code block to control their behaviour. They are
+variations on similar core perl or List::Util functions of similar
+names, but which use the block to control their behaviour. For
+example, the core Perl function sort takes a list of values and
+returns them, sorted into order by their string value. The sort_by
+function sorts them according to the string value returned by the
+extra function, when given each value.
+
+WWW: http://search.cpan.org/dist/List-UtilsBy/
diff --git a/devel/p5-List-UtilsBy/pkg-plist b/devel/p5-List-UtilsBy/pkg-plist
new file mode 100644
index 000000000000..5eee2be5f130
--- /dev/null
+++ b/devel/p5-List-UtilsBy/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/List/UtilsBy/.packlist
+%%SITE_PERL%%/List/UtilsBy.pm
+@dirrmtry %%SITE_PERL%%/List
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/List/UtilsBy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List