aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Log-Dispatch-FileShared/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Log-Dispatch-FileShared/Makefile')
-rw-r--r--devel/p5-Log-Dispatch-FileShared/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-Log-Dispatch-FileShared/Makefile b/devel/p5-Log-Dispatch-FileShared/Makefile
new file mode 100644
index 000000000000..bdd8341faeb5
--- /dev/null
+++ b/devel/p5-Log-Dispatch-FileShared/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Log-Dispatch-FileShared
+# Date created: 3 February 2007
+# Whom: Craig Manley
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatch-FileShared
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Log
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A Log::Dispatch output class for logging to shared files
+
+BUILD_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatch::FileShared.3
+
+.include <bsd.port.mk>