aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Log-Dispatch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Log-Dispatch/Makefile')
-rw-r--r--devel/p5-Log-Dispatch/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
new file mode 100644
index 000000000000..39529fbeb815
--- /dev/null
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: devel/p5-Log-Dispatch
+# Date created: 17 May 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Dispatch
+PORTVERSION= 1.79
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Log
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Dispatch.3 \
+ Log::Dispatch::ApacheLog.3 \
+ Log::Dispatch::Base.3 \
+ Log::Dispatch::Email.3 \
+ Log::Dispatch::Email::MIMELite.3 \
+ Log::Dispatch::Email::MailSend.3 \
+ Log::Dispatch::Email::MailSendmail.3 \
+ Log::Dispatch::File.3 \
+ Log::Dispatch::Handle.3 \
+ Log::Dispatch::Output.3 \
+ Log::Dispatch::Screen.3 \
+ Log::Dispatch::Syslog.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+SCRIPTS_ENV+= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ REALCURDIR="${.CURDIR}"
+
+pre-fetch:
+ @${SETENV} ${SCRIPTS_ENV} ${PERL} ${SCRIPTDIR}/configure.pl
+
+post-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.endif
+
+.include <bsd.port.mk>