aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Log-Dispatch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Log-Dispatch/Makefile')
-rw-r--r--devel/p5-Log-Dispatch/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/p5-Log-Dispatch/Makefile b/devel/p5-Log-Dispatch/Makefile
index a33f92981cee..b79193103c68 100644
--- a/devel/p5-Log-Dispatch/Makefile
+++ b/devel/p5-Log-Dispatch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Log-Dispatch
-PORTVERSION= 2.12
+PORTVERSION= 2.13
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Log
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= A suite of OO modules for logging messages to multiple outputs
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Params-Validate>=0.15:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
@@ -55,26 +55,26 @@ post-install:
.if defined(WITH_APACHELOG)
.if defined(WITH_APACHE2)
BROKEN= Broken due the new mod_perl2 API
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
.else
-BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl
.endif
.endif
.if defined(WITH_EMAIL_MIMELITE)
-BUILD_DEPENDS+= ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite
+RUN_DEPENDS+= ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite
.endif
.if defined(WITH_EMAIL_MAILSEND)
-BUILD_DEPENDS+= ${SITE_PERL}/Mail/Send.pm:${PORTSDIR}/mail/p5-Mail-Tools
+RUN_DEPENDS+= ${SITE_PERL}/Mail/Send.pm:${PORTSDIR}/mail/p5-Mail-Tools
.endif
.if !defined(WITHOUT_EMAIL_MAILSENDMAIL)
-BUILD_DEPENDS+= ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail
+RUN_DEPENDS+= ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail
.endif
.if defined(WITH_MAIL_SENDER)
-BUILD_DEPENDS+= ${SITE_PERL}/Mail/Sender.pm:${PORTSDIR}/mail/p5-Mail-Sender
+RUN_DEPENDS+= ${SITE_PERL}/Mail/Sender.pm:${PORTSDIR}/mail/p5-Mail-Sender
.endif
.include <bsd.port.post.mk>