aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Mixin-Linewise/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Mixin-Linewise/Makefile')
-rw-r--r--devel/p5-Mixin-Linewise/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/p5-Mixin-Linewise/Makefile b/devel/p5-Mixin-Linewise/Makefile
index e4c5178b4a3c..90472471f922 100644
--- a/devel/p5-Mixin-Linewise/Makefile
+++ b/devel/p5-Mixin-Linewise/Makefile
@@ -19,17 +19,22 @@ COMMENT= Write your linewise code for handles; this does the rest
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
+.include <bsd.port.pre.mk>
+
BUILD_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
RUN_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
PERL_CONFIGURE= yes
MAN3= Mixin::Linewise::Readers.3 \
Mixin::Linewise::Writers.3 \
Mixin::Linewise.3
-
PLIST_FILES+= %%SITE_PERL%%/Mixin/Linewise/Readers.pm \
%%SITE_PERL%%/Mixin/Linewise/Writers.pm \
%%SITE_PERL%%/Mixin/Linewise.pm \
@@ -39,4 +44,4 @@ PLIST_DIRS+= %%SITE_PERL%%/Mixin/Linewise \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixin/Linewise \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>