aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE-Component-Hailo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-POE-Component-Hailo/Makefile')
-rw-r--r--devel/p5-POE-Component-Hailo/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/p5-POE-Component-Hailo/Makefile b/devel/p5-POE-Component-Hailo/Makefile
new file mode 100644
index 000000000000..d8382d1ff24a
--- /dev/null
+++ b/devel/p5-POE-Component-Hailo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: POE-Componenet-Hailo
+# Date created: 2011-07-19
+# Whom: milki <milki@rescomp.berkeley.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Hailo
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:HINRIK
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= A non-blocking wrapper around Hailo
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Hailo>=0:${PORTSDIR}/textproc/p5-Hailo
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Hailo.3
+
+.include <bsd.port.mk>