aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-POE/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-POE/Makefile')
-rw-r--r--devel/p5-POE/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/devel/p5-POE/Makefile b/devel/p5-POE/Makefile
index 831f2a83de63..19a988d3093a 100644
--- a/devel/p5-POE/Makefile
+++ b/devel/p5-POE/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= POE
-PORTVERSION= 0.1502
+PORTVERSION= 0.17
CATEGORIES= devel perl5
MASTER_SITES= http://poe.perl.org/poedown/ ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= POE
@@ -25,20 +25,23 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-MAN3= POE::Driver::SysRW.3 POE::Wheel::ListenAccept.3\
- POE::Filter::Grep.3 POE::Session.3 POE::Filter::Reference.3\
- POE::Wheel::SocketFactory.3 POE::Filter.3 POE::Preprocessor.3\
- POE::Pipe.3\
- POE::Pipe::TwoWay.3 POE::Wheel::ReadLine.3 POE::Wheel::ReadWrite.3\
- POE::Driver.3 POE::Component::Server::TCP.3 POE::Pipe::OneWay.3\
- POE.3 POE::Component.3 POE::Filter::Map.3 POE::Wheel.3 POE::NFA.3\
- POE::Wheel::Run.3 POE::Filter::HTTPD.3 POE::Filter::Line.3\
- POE::Filter::Stackable.3 POE::Filter::RecordBlock.3\
- POE::Filter::Block.3 POE::Wheel::FollowTail.3 POE::Kernel.3\
- POE::Filter::Stream.3 POE::Wheel::Curses.3
+MAN3= POE.3 POE::Component.3 POE::Component::Server::TCP.3 \
+ POE::Driver.3 POE::Driver::SysRW.3 POE::Filter.3 \
+ POE::Filter::Block.3 POE::Filter::Grep.3 POE::Filter::HTTPD.3 \
+ POE::Filter::Line.3 POE::Filter::Map.3 \
+ POE::Filter::RecordBlock.3 POE::Filter::Reference.3 \
+ POE::Filter::Stackable.3 POE::Filter::Stream.3 POE::Kernel.3 \
+ POE::NFA.3 POE::Pipe.3 POE::Pipe::OneWay.3 POE::Pipe::TwoWay.3 \
+ POE::Preprocessor.3 POE::Session.3 POE::Wheel.3 \
+ POE::Wheel::Curses.3 POE::Wheel::FollowTail.3 \
+ POE::Wheel::ListenAccept.3 POE::Wheel::ReadLine.3 \
+ POE::Wheel::ReadWrite.3 POE::Wheel::Run.3 \
+ POE::Wheel::SocketFactory.3
post-install:
+.ifndef(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/samples/* ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+.endif
.include <bsd.port.mk>