aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Perl-Version/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Perl-Version/Makefile')
-rw-r--r--devel/p5-Perl-Version/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/p5-Perl-Version/Makefile b/devel/p5-Perl-Version/Makefile
index c6a7b0e2ad89..277fa91e9f44 100644
--- a/devel/p5-Perl-Version/Makefile
+++ b/devel/p5-Perl-Version/Makefile
@@ -16,11 +16,18 @@ COMMENT= Parse and manipulate Perl version strings
RUN_DEPENDS= p5-File-Slurp>=9999.12:${PORTSDIR}/devel/p5-File-Slurp \
p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= perl-reversion.1
MAN3= Perl::Version.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 5.008007
+RUN_DEPENDS+= p5-Pod-Parser>=1.3:${PORTSDIR}/textproc/p5-Pod-Parser
+BUILD_DEPENDS+= p5-Pod-Parser>=1.3:${PORTSDIR}/textproc/p5-Pod-Parser
+.endif
+
+.include <bsd.port.post.mk>