aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Pod-Coverage-TrustPod/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Pod-Coverage-TrustPod/Makefile')
-rw-r--r--devel/p5-Pod-Coverage-TrustPod/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/devel/p5-Pod-Coverage-TrustPod/Makefile b/devel/p5-Pod-Coverage-TrustPod/Makefile
index a06119f099f1..5091c3f6513f 100644
--- a/devel/p5-Pod-Coverage-TrustPod/Makefile
+++ b/devel/p5-Pod-Coverage-TrustPod/Makefile
@@ -18,13 +18,21 @@ COMMENT= Declare trusted symbol names in POD
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Pod-Coverage \
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS+= p5-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Pod-Coverage \
+ p5-Pod-Eventual>=0:${PORTSDIR}/textproc/p5-Pod-Eventual
+RUN_DEPENDS+= p5-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Pod-Coverage \
p5-Pod-Eventual>=0:${PORTSDIR}/textproc/p5-Pod-Eventual
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Pod>=1.41:${PORTSDIR}/devel/p5-Test-Pod
+
+TEST_DEPENDS+= p5-Test-Pod>=1.41:${PORTSDIR}/devel/p5-Test-Pod
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
PERL_CONFIGURE= yes
MAN3= Pod::Coverage::TrustPod.3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>