aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SSN-Validate
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-SSN-Validate')
-rw-r--r--devel/p5-SSN-Validate/Makefile32
-rw-r--r--devel/p5-SSN-Validate/distinfo3
-rw-r--r--devel/p5-SSN-Validate/pkg-descr8
-rw-r--r--devel/p5-SSN-Validate/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-SSN-Validate/Makefile b/devel/p5-SSN-Validate/Makefile
new file mode 100644
index 000000000000..ac03ff6c30e8
--- /dev/null
+++ b/devel/p5-SSN-Validate/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-SSN-Validate
+# Date created: 17 Jan 2006
+# Whom: tiger <tiger@whitetigersd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SSN-Validate
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/K/KM/KMELTZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tiger@whitetigersd.com
+COMMENT= Perl extension to do SSN Validation
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+MAN3= SSN::Validate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or higher
+.endif
+
+test: all
+ cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-SSN-Validate/distinfo b/devel/p5-SSN-Validate/distinfo
new file mode 100644
index 000000000000..6351165914fc
--- /dev/null
+++ b/devel/p5-SSN-Validate/distinfo
@@ -0,0 +1,3 @@
+MD5 (SSN-Validate-0.14.tar.gz) = b79e9d7929478e43a7430cf874b0a4ae
+SHA256 (SSN-Validate-0.14.tar.gz) = 2eda951bedfb7fedcce710e99cd0d539f3f8184005cff8cfc41a75e3bed551a4
+SIZE (SSN-Validate-0.14.tar.gz) = 12326
diff --git a/devel/p5-SSN-Validate/pkg-descr b/devel/p5-SSN-Validate/pkg-descr
new file mode 100644
index 000000000000..9b41e7ebc942
--- /dev/null
+++ b/devel/p5-SSN-Validate/pkg-descr
@@ -0,0 +1,8 @@
+This module is intented to do some Social Security Number validation
+(not verification) beyond just seeing if it contains 9 digits and isn't
+all 0s. The data is taken from the Social Security Admin. website,
+specifically:
+
+http://www.ssa.gov/foia/stateweb.html
+
+WWW: http://search.cpan.org/dist/SSN-Validate
diff --git a/devel/p5-SSN-Validate/pkg-plist b/devel/p5-SSN-Validate/pkg-plist
new file mode 100644
index 000000000000..6a0405482b6a
--- /dev/null
+++ b/devel/p5-SSN-Validate/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SSN/Validate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SSN/Validate/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SSN/Validate 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SSN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/SSN 2>/dev/null || true