aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Set-Object
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Set-Object')
-rw-r--r--devel/p5-Set-Object/Makefile9
-rw-r--r--devel/p5-Set-Object/files/patch-makeitwork28
2 files changed, 34 insertions, 3 deletions
diff --git a/devel/p5-Set-Object/Makefile b/devel/p5-Set-Object/Makefile
index 20192d5b7cb8..140dd20a0084 100644
--- a/devel/p5-Set-Object/Makefile
+++ b/devel/p5-Set-Object/Makefile
@@ -7,12 +7,13 @@
PORTNAME= Set-Object
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Set
PKGNAMEPREFIX= p5-
-MAINTAINER= tobez@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module to manage sets of objects
PERL_CONFIGURE= yes
@@ -21,8 +22,10 @@ MAN3= Set::Object.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-BROKEN= "Does not compile with this version of perl"
+.if ${PERL_LEVEL} < 500600
+EXTRA_DEPEND= ${SITE_PERL}/${PERL_ARCH}/Devel/Peek.pm:${PORTSDIR}/devel/p5-Devel-Peek
+BUILD_DEPENDS+= ${EXTRA_DEPEND}
+RUN_DEPENDS+= ${EXTRA_DEPEND}
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Set-Object/files/patch-makeitwork b/devel/p5-Set-Object/files/patch-makeitwork
new file mode 100644
index 000000000000..6d328430d832
--- /dev/null
+++ b/devel/p5-Set-Object/files/patch-makeitwork
@@ -0,0 +1,28 @@
+diff -ruN Set-Object-1.05/Makefile.PL ../Set-Object-1.05/Makefile.PL
+--- Makefile.PL Tue May 20 15:12:29 2003
++++ Makefile.PL Mon Apr 19 15:26:49 2004
+@@ -5,6 +5,6 @@
+ 'NAME' => 'Set::Object',
+ 'VERSION_FROM' => 'Object.pm', # finds $VERSION
+ 'LIBS' => [''], # e.g., '-lm'
+- 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
++ 'DEFINE' => $] < 5.006 ? '-DaTHX_=""' : '', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => '', # e.g., '-I/usr/include/other'
+ );
+diff -ruN Set-Object-1.05/Object.xs ../Set-Object-1.05/Object.xs
+--- Object.xs Wed Sep 3 01:16:28 2003
++++ Object.xs Mon Apr 19 15:38:49 2004
+@@ -522,7 +522,7 @@
+ // (less "Use of uninitialised value..." messages)
+
+ // XSRETURN_UNDEF;
+- RETVAL = PTR2UV(SvRV(sv));
++ RETVAL = (UV)(SvRV(sv));
+ }
+ }
+ OUTPUT:
+diff -ruN Set-Object-1.05/typemap ../Set-Object-1.05/typemap
+--- typemap Thu Jan 1 01:00:00 1970
++++ typemap Mon Apr 19 15:36:03 2004
+@@ -0,0 +1 @@
++UV T_IV