aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Spoon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Spoon/Makefile')
-rw-r--r--devel/p5-Spoon/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/devel/p5-Spoon/Makefile b/devel/p5-Spoon/Makefile
index 7c814664d82b..11f1a171411a 100644
--- a/devel/p5-Spoon/Makefile
+++ b/devel/p5-Spoon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Spoon
-PORTVERSION= 0.20
+PORTVERSION= 0.21
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
@@ -25,11 +25,12 @@ PERL_CONFIGURE= yes
MAN3= Spoon.3 \
Spoon::Base.3 \
Spoon::CGI.3 \
+ Spoon::Command.3 \
Spoon::ContentObject.3 \
Spoon::Cookie.3 \
Spoon::DataObject.3 \
Spoon::Formatter.3 \
- Spoon::Hook.3 \
+ Spoon::Hooks.3 \
Spoon::Hub.3 \
Spoon::Installer.3 \
Spoon::MetadataObject.3 \
@@ -39,6 +40,15 @@ MAN3= Spoon.3 \
Spoon::Template::TT2.3 \
Spoon::Utils.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800