aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Exception/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-Exception/Makefile')
-rw-r--r--devel/p5-Test-Exception/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Test-Exception/Makefile b/devel/p5-Test-Exception/Makefile
new file mode 100644
index 000000000000..22d7a4f647aa
--- /dev/null
+++ b/devel/p5-Test-Exception/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Test-Exception
+# Date created: January 27th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Exception
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Test::Exception.3
+
+.include <bsd.port.pre.mk>
+
+##
+## this port depends on devel/p5-Sub-Uplevel which
+## requires PERL 5.6.x or later
+##
+.if ${PERL_LEVEL} < 500600
+BROKEN= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>