aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Inline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-Inline/Makefile')
-rw-r--r--devel/p5-Test-Inline/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
index de0c460046ac..176aa9279992 100644
--- a/devel/p5-Test-Inline/Makefile
+++ b/devel/p5-Test-Inline/Makefile
@@ -15,23 +15,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Test::Inline - Inlining your tests next to the code being tested
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN1= pod2test.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Pod::Tests.3 Pod::Tests::Tutorial.3 Test::Inline.3 Test::Inline::Tutorial.3
.include <bsd.port.pre.mk>
-SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>