aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Inline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-Inline/Makefile')
-rw-r--r--devel/p5-Test-Inline/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/p5-Test-Inline/Makefile b/devel/p5-Test-Inline/Makefile
index 12d99fa7b499..f4662d9ac223 100644
--- a/devel/p5-Test-Inline/Makefile
+++ b/devel/p5-Test-Inline/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= p5-Algorithm-Dependency>=1.02:${PORTSDIR}/devel/p5-Algorithm-Depend
p5-File-chmod>=0.31:${PORTSDIR}/devel/p5-File-chmod \
p5-Params-Util>=0.21:${PORTSDIR}/devel/p5-Params-Util \
p5-Pod-Tests>=0.18:${PORTSDIR}/devel/p5-Pod-Tests
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
BUILD_DEPENDS+= p5-Test-ClassAPI>=1.02:${PORTSDIR}/devel/p5-Test-ClassAPI \
p5-Test-Script>=1.02:${PORTSDIR}/devel/p5-Test-Script
@@ -41,4 +41,10 @@ MAN3= Test::Inline.3 \
Test::Inline::Script.3 \
Test::Inline::Section.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500905
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.19:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>