aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-MockRandom/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-MockRandom/Makefile')
-rw-r--r--devel/p5-Test-MockRandom/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/p5-Test-MockRandom/Makefile b/devel/p5-Test-MockRandom/Makefile
new file mode 100644
index 000000000000..ceace55f991d
--- /dev/null
+++ b/devel/p5-Test-MockRandom/Makefile
@@ -0,0 +1,22 @@
+# New Ports Collection Makefile for: p5-Test-MockRandom
+# Date created: 2006-07-23
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+# $FreeBSD$
+
+PORTNAME= Test-MockRandom
+PORTVERSION= 0.99
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Replaces random number generation with non-random number generation
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::MockRandom.3
+
+.include <bsd.port.mk>