aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Pod
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-Pod')
-rw-r--r--devel/p5-Test-Pod/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/p5-Test-Pod/Makefile b/devel/p5-Test-Pod/Makefile
index bfa0e30ba197..e862a20213ba 100644
--- a/devel/p5-Test-Pod/Makefile
+++ b/devel/p5-Test-Pod/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= mat@FreeBSD.org
COMMENT= Check for POD errors in files
BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
${SITE_PERL}/Pod/Simple.pm:${PORTSDIR}/textproc/p5-Pod-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -31,5 +30,8 @@ MAN3= Test::Pod.3
post-patch:
@${PERL} -pi -e 's/(my )?\$$dh/DH/g' ${WRKSRC}/Pod.pm
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
.include <bsd.port.post.mk>