aboutsummaryrefslogtreecommitdiff
path: root/devel/pcre
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pcre')
-rw-r--r--devel/pcre/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index f3bbd7f554af..94ea234ff93e 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -18,4 +18,9 @@ USE_LIBTOOL= yes
MAN3= pcre.3 pcreposix.3
MAN1= pgrep.1
+# Otherwise we get a broken pgrep shell script installed
+# instead of the binary we really want.
+pre-install:
+ @${LN} -f ${WRKSRC}/.libs/pgrep ${WRKSRC}/pgrep
+
.include <bsd.port.mk>