aboutsummaryrefslogtreecommitdiff
path: root/devel/pcsc-lite
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pcsc-lite')
-rw-r--r--devel/pcsc-lite/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index b9b61621d287..356f9bbaa550 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -38,11 +38,17 @@ MAN8= pcscd.8
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_USB) && ${OSVERSION} >= 800069
-CONFIGURE_ENV+= LIBUSB_LIBS="-lusb"
+.if ${OSVERSION} >= 800069
+OPTIONS_DEFINE= USB
+OPTIONS_DEFAULT=USB
+
+USB_DESC= Support for USB-reader
+
+.if $(PORT_OPTIONS:MUSB)
+CONFIGURE_ENV+= LIBUSB_LIBS="-lusb"
CONFIGURE_ARGS+=--enable-libusb=/usr
-.else
-BROKEN= FreeBSD 7.x does not ship with a supported libusb
+.endif
+
.endif
post-patch:
@@ -56,14 +62,6 @@ post-patch:
${REINPLACE_CMD} -e '/^install-data-am: / s|install-docDATA||' ${WRKSRC}/doc/Makefile.in
.endif
-pre-everything::
-.if !defined(WITHOUT_USB) && ${OSVERSION} >= 800069
- @${ECHO_MSG}
- @${ECHO_MSG} "pcsc-lite has the following option(s):"
- @${ECHO_MSG} " WITHOUT_USB=yes Disable USB support"
- @${ECHO_MSG}
-.endif
-
post-install:
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}