aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Date/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-Date/Makefile')
-rw-r--r--devel/pear-Date/Makefile23
1 files changed, 3 insertions, 20 deletions
diff --git a/devel/pear-Date/Makefile b/devel/pear-Date/Makefile
index e404ff8c069a..e0d485fe916a 100644
--- a/devel/pear-Date/Makefile
+++ b/devel/pear-Date/Makefile
@@ -7,32 +7,19 @@
PORTNAME= Date
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR Date and Time Zone Classes
-BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
NO_BUILD= yes
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
MANIFEST= Date Date.php
@@ -42,8 +29,4 @@ do-install:
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${FILE}
.endfor
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>