aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-HTML_Common/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-HTML_Common/Makefile')
-rw-r--r--devel/pear-HTML_Common/Makefile26
1 files changed, 3 insertions, 23 deletions
diff --git a/devel/pear-HTML_Common/Makefile b/devel/pear-HTML_Common/Makefile
index e24a4e0c7b9b..2212f83429a4 100644
--- a/devel/pear-HTML_Common/Makefile
+++ b/devel/pear-HTML_Common/Makefile
@@ -6,41 +6,21 @@
#
PORTNAME= HTML_Common
-PORTVERSION= 1.0
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= devel www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR::HTML_Common is a base class for other HTML classes
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
@${MKDIR} ${PEARDIR}/HTML
@${CP} -Rp ${WRKSRC}/Common.php ${PEARDIR}/HTML
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/HTML
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>