aboutsummaryrefslogtreecommitdiff
path: root/devel/piklab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/piklab/Makefile')
-rw-r--r--devel/piklab/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/piklab/Makefile b/devel/piklab/Makefile
index bbe26be3943e..dd30ffaeda26 100644
--- a/devel/piklab/Makefile
+++ b/devel/piklab/Makefile
@@ -3,7 +3,7 @@
PORTNAME= piklab
PORTVERSION= 0.16.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel kde
MASTER_SITES= SF
@@ -12,14 +12,16 @@ COMMENT= KDE/Qt IDE for microcontroller development
LICENSE= GPLv2+
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
DOS2UNIX_FILES= cmake/Piklab.cmake
USE_QT= corelib gui qt3support qtestlib xml \
- moc_build qmake_build rcc_build uic_build
+ moc_build qmake_build rcc_build uic_build network
USES= cmake gettext qt:4 readline dos2unix tar:bzip2
USE_CXXSTD= gnu++98
OPTIONS_DEFINE= KDE4
-OPTIONS_DEFAULT= KDE4
OPTIONS_SUB= yes
KDE4_USES= kde:4 shared-mime-info
@@ -27,6 +29,7 @@ KDE4_USE= KDE=automoc4,kdelibs
KDE4_CMAKE_OFF= -DQT_ONLY:BOOL=ON \
-DLOCALE_INSTALL_DIR:STRING="${PREFIX}/share/locale"
+BROKEN= does not link
BROKEN_sparc64= does not compile on sparc64
post-patch: