aboutsummaryrefslogtreecommitdiff
path: root/devel/ppl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ppl/Makefile')
-rw-r--r--devel/ppl/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/ppl/Makefile b/devel/ppl/Makefile
new file mode 100644
index 000000000000..84200852a57b
--- /dev/null
+++ b/devel/ppl/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: ppl
+# Date created: Feb 5, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ppl
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.cs.unipr.it/pub/ppl/releases/${PORTVERSION}/ \
+ http://www.cs.unipr.it/ppl/Download/ftp/releases/${PORTVERSION}/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gmp.5:${PORTSDIR}/math/libgmp4
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-cxxflags="${CXXFLAGS}"
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>