aboutsummaryrefslogtreecommitdiff
path: root/devel/preps-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/preps-gui/Makefile')
-rw-r--r--devel/preps-gui/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/preps-gui/Makefile b/devel/preps-gui/Makefile
new file mode 100644
index 000000000000..b6fc746dd94e
--- /dev/null
+++ b/devel/preps-gui/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: preps-gui
+# Date created: Fri Mar 19 14:27:30 EET 2004
+# Whom: shadow@psoft.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= preps-gui
+PORTVERSION= 1.8.1
+CATEGORIES= devel
+MASTER_SITES= http://webpages.charter.net/stuffle/linux/preps/
+DISTNAME= preps-${PORTVERSION}
+DIST_SUBDIR= prep
+
+MAINTAINER= shadow@psoft.net
+COMMENT= Problem reporting system
+
+LIB_DEPENDS+= preps-1.6.1:${PORTSDIR}/devel/libpreps
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gtk12 gnomelibs
+MAN1= preps.1
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-pgsqldir=${LOCALBASE} \
+ --with-plpgsqldir=${LOCALBASE} \
+ --with-libprepsdir=${LOCALBASE}
+
+.include <bsd.port.mk>