aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib152/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pwlib152/files')
-rw-r--r--devel/pwlib152/files/patch-configurein19
-rw-r--r--devel/pwlib152/files/patch-makefile14
-rw-r--r--devel/pwlib152/files/patch-unix70
-rw-r--r--devel/pwlib152/files/patch-videoio36
4 files changed, 0 insertions, 139 deletions
diff --git a/devel/pwlib152/files/patch-configurein b/devel/pwlib152/files/patch-configurein
deleted file mode 100644
index a53c4f7e9403..000000000000
--- a/devel/pwlib152/files/patch-configurein
+++ /dev/null
@@ -1,19 +0,0 @@
-*** configure.in.orig Sun Aug 31 09:31:23 2003
---- configure.in Sun Aug 31 09:31:50 2003
-*************** case "$target_os" in
-*** 39,45 ****
- STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
-
- freebsd* ) OSTYPE=FreeBSD ;
-! OSRELEASE=`sysctl -n kern.osreldate` ;
- STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
-
- openbsd* ) OSTYPE=OpenBSD ;
---- 39,45 ----
- STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
-
- freebsd* ) OSTYPE=FreeBSD ;
-! ## use enviroment variable OSRELEASE=`sysctl -n kern.osreldate` ;
- STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
-
- openbsd* ) OSTYPE=OpenBSD ;
diff --git a/devel/pwlib152/files/patch-makefile b/devel/pwlib152/files/patch-makefile
deleted file mode 100644
index 8ca3ca5e99f7..000000000000
--- a/devel/pwlib152/files/patch-makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-*** src/ptlib/unix/Makefile.orig Tue Dec 2 11:15:55 2003
---- src/ptlib/unix/Makefile Tue Dec 2 11:16:39 2003
-*************** VIDEO_CAPTURE_SOURCE = video4linux.cxx
-*** 422,428 ****
---- 422,430 ----
- endif
-
- ifeq ($(OSTYPE),FreeBSD)
-+ ifneq (,$(wildcard $(SYSINCDIR)/machine/ioctl_meteor.h))
- VIDEO_CAPTURE_SOURCE = video4bsd.cxx
-+ endif
- endif
-
- ifeq ($(OSTYPE),OpenBSD)
diff --git a/devel/pwlib152/files/patch-unix b/devel/pwlib152/files/patch-unix
deleted file mode 100644
index 205bd870e479..000000000000
--- a/devel/pwlib152/files/patch-unix
+++ /dev/null
@@ -1,70 +0,0 @@
-*** make/unix.mak.orig Thu Aug 28 08:39:18 2003
---- make/unix.mak Thu Aug 28 08:42:30 2003
-*************** endif # linux
-*** 338,348 ****
-
- ifeq ($(OSTYPE),FreeBSD)
-
-! ifeq ($(MACHTYPE),x86)
-! ifdef CPUTYPE
-! STDCCFLAGS += -mcpu=$(CPUTYPE)
-! endif
-! endif
-
- ifndef OSRELEASE
- OSRELEASE := $(shell sysctl -n kern.osreldate)
---- 338,348 ----
-
- ifeq ($(OSTYPE),FreeBSD)
-
-! #ifeq ($(MACHTYPE),x86)
-! #ifdef CPUTYPE
-! #STDCCFLAGS += -mcpu=$(CPUTYPE)
-! #endif
-! #endif
-
- ifndef OSRELEASE
- OSRELEASE := $(shell sysctl -n kern.osreldate)
-*************** SHELL := /bin/sh
-*** 871,881 ****
-
- # Directories
-
-! ifdef PREFIX
-! UNIX_INC_DIR = $(PREFIX)/include/ptlib/unix
-! else
- UNIX_INC_DIR = $(PWLIBDIR)/include/ptlib/unix
-! endif
-
- ifndef UNIX_SRC_DIR
- UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
---- 871,881 ----
-
- # Directories
-
-! ##ifdef PREFIX
-! ##UNIX_INC_DIR = $(PREFIX)/include/ptlib/unix
-! ##else
- UNIX_INC_DIR = $(PWLIBDIR)/include/ptlib/unix
-! ##endif
-
- ifndef UNIX_SRC_DIR
- UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
-*************** LDFLAGS += $(DEBLDFLAGS)
-*** 912,918 ****
- else
-
- ifneq ($(OSTYPE),Darwin)
-! OPTCCFLAGS += -O3 -DNDEBUG
- else
- OPTCCFLAGS += -O2 -DNDEBUG
- endif
---- 912,919 ----
- else
-
- ifneq ($(OSTYPE),Darwin)
-! # OPTCCFLAGS += -O3 -DNDEBUG
-! OPTCCFLAGS += -DNDEBUG
- else
- OPTCCFLAGS += -O2 -DNDEBUG
- endif
diff --git a/devel/pwlib152/files/patch-videoio b/devel/pwlib152/files/patch-videoio
deleted file mode 100644
index 74d8a5c43c02..000000000000
--- a/devel/pwlib152/files/patch-videoio
+++ /dev/null
@@ -1,36 +0,0 @@
-*** include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 18:41:08 2003
---- include/ptlib/unix/ptlib/videoio.h Tue Dec 2 09:42:10 2003
-***************
-*** 106,112 ****
- #include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
- #endif
-
-! #if defined(P_FREEBSD)
- #include <machine/ioctl_meteor.h>
- #endif
-
---- 106,112 ----
- #include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
- #endif
-
-! #if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
- #include <machine/ioctl_meteor.h>
- #endif
-
-***************
-*** 186,192 ****
- struct video_mmap frameBuffer[2];
- #endif
-
-! #if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
- struct video_capability
- {
- int channels; /* Num channels */
---- 186,192 ----
- struct video_mmap frameBuffer[2];
- #endif
-
-! #if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
- struct video_capability
- {
- int channels; /* Num channels */