aboutsummaryrefslogtreecommitdiff
path: root/devel/pwlib152
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pwlib152')
-rw-r--r--devel/pwlib152/Makefile41
-rw-r--r--devel/pwlib152/distinfo1
-rw-r--r--devel/pwlib152/files/patch-configurein19
-rw-r--r--devel/pwlib152/files/patch-makefile14
-rw-r--r--devel/pwlib152/files/patch-unix70
-rw-r--r--devel/pwlib152/files/patch-videoio36
-rw-r--r--devel/pwlib152/pkg-descr12
-rw-r--r--devel/pwlib152/pkg-plist0
8 files changed, 0 insertions, 193 deletions
diff --git a/devel/pwlib152/Makefile b/devel/pwlib152/Makefile
deleted file mode 100644
index c421ce64050d..000000000000
--- a/devel/pwlib152/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: pwlib
-# Date created: Fri Aug 22 07:11:44 GMT 2003
-# Whom: Roger Hardiman <roger@freebsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= pwlib
-PORTVERSION= 1.5.0
-PORTREVISION= 2
-CATEGORIES= devel
-MASTER_SITES= http://www.openh323.org/bin/ \
- http://www.de.openh323.org/bin/ \
- http://www.gnomemeeting.org/downloads/0.98.0/sources/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
-
-MAINTAINER= roger@freebsd.org
-COMMENT= A cross platform C++ library, used by OpenH323
-
-LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-USE_BISON= yes
-
-USE_GMAKE= yes
-USE_AUTOCONF= yes
-USE_OPENLDAP= yes
-WANT_AUTOCONF_VER= 253
-CONFIGURE_ENV= OSRELEASE=${OSVERSION}
-ALL_TARGET= optnoshared
-MAKE_ENV= PWLIBDIR=${WRKDIR}/pwlib
-THE_MACHTYPE= ${ARCH:S/i386/x86/}
-MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
-
-ONLY_FOR_ARCHS= i386
-
-do-install:
-# ${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/devel/pwlib152/distinfo b/devel/pwlib152/distinfo
deleted file mode 100644
index 0126a1101fe7..000000000000
--- a/devel/pwlib152/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (pwlib_1.5.0.tar.gz) = e6bcdd121a85687c040f4871f24b7352
diff --git a/devel/pwlib152/files/patch-configurein b/devel/pwlib152/files/patch-configurein
deleted file mode 100644
index a53c4f7e9403..000000000000
--- a/devel/pwlib152/files/patch-configurein
+++ /dev/null
@@ -1,19 +0,0 @@
-*** configure.in.orig Sun Aug 31 09:31:23 2003
---- configure.in Sun Aug 31 09:31:50 2003
-*************** case "$target_os" in
-*** 39,45 ****
- STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
-
- freebsd* ) OSTYPE=FreeBSD ;
-! OSRELEASE=`sysctl -n kern.osreldate` ;
- STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
-
- openbsd* ) OSTYPE=OpenBSD ;
---- 39,45 ----
- STDCCFLAGS="-DP_LINUX=$OSRELEASE" ;;
-
- freebsd* ) OSTYPE=FreeBSD ;
-! ## use enviroment variable OSRELEASE=`sysctl -n kern.osreldate` ;
- STDCCFLAGS="-DP_FREEBSD=$OSRELEASE" ;;
-
- openbsd* ) OSTYPE=OpenBSD ;
diff --git a/devel/pwlib152/files/patch-makefile b/devel/pwlib152/files/patch-makefile
deleted file mode 100644
index 8ca3ca5e99f7..000000000000
--- a/devel/pwlib152/files/patch-makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-*** src/ptlib/unix/Makefile.orig Tue Dec 2 11:15:55 2003
---- src/ptlib/unix/Makefile Tue Dec 2 11:16:39 2003
-*************** VIDEO_CAPTURE_SOURCE = video4linux.cxx
-*** 422,428 ****
---- 422,430 ----
- endif
-
- ifeq ($(OSTYPE),FreeBSD)
-+ ifneq (,$(wildcard $(SYSINCDIR)/machine/ioctl_meteor.h))
- VIDEO_CAPTURE_SOURCE = video4bsd.cxx
-+ endif
- endif
-
- ifeq ($(OSTYPE),OpenBSD)
diff --git a/devel/pwlib152/files/patch-unix b/devel/pwlib152/files/patch-unix
deleted file mode 100644
index 205bd870e479..000000000000
--- a/devel/pwlib152/files/patch-unix
+++ /dev/null
@@ -1,70 +0,0 @@
-*** make/unix.mak.orig Thu Aug 28 08:39:18 2003
---- make/unix.mak Thu Aug 28 08:42:30 2003
-*************** endif # linux
-*** 338,348 ****
-
- ifeq ($(OSTYPE),FreeBSD)
-
-! ifeq ($(MACHTYPE),x86)
-! ifdef CPUTYPE
-! STDCCFLAGS += -mcpu=$(CPUTYPE)
-! endif
-! endif
-
- ifndef OSRELEASE
- OSRELEASE := $(shell sysctl -n kern.osreldate)
---- 338,348 ----
-
- ifeq ($(OSTYPE),FreeBSD)
-
-! #ifeq ($(MACHTYPE),x86)
-! #ifdef CPUTYPE
-! #STDCCFLAGS += -mcpu=$(CPUTYPE)
-! #endif
-! #endif
-
- ifndef OSRELEASE
- OSRELEASE := $(shell sysctl -n kern.osreldate)
-*************** SHELL := /bin/sh
-*** 871,881 ****
-
- # Directories
-
-! ifdef PREFIX
-! UNIX_INC_DIR = $(PREFIX)/include/ptlib/unix
-! else
- UNIX_INC_DIR = $(PWLIBDIR)/include/ptlib/unix
-! endif
-
- ifndef UNIX_SRC_DIR
- UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
---- 871,881 ----
-
- # Directories
-
-! ##ifdef PREFIX
-! ##UNIX_INC_DIR = $(PREFIX)/include/ptlib/unix
-! ##else
- UNIX_INC_DIR = $(PWLIBDIR)/include/ptlib/unix
-! ##endif
-
- ifndef UNIX_SRC_DIR
- UNIX_SRC_DIR = $(PWLIBDIR)/src/ptlib/unix
-*************** LDFLAGS += $(DEBLDFLAGS)
-*** 912,918 ****
- else
-
- ifneq ($(OSTYPE),Darwin)
-! OPTCCFLAGS += -O3 -DNDEBUG
- else
- OPTCCFLAGS += -O2 -DNDEBUG
- endif
---- 912,919 ----
- else
-
- ifneq ($(OSTYPE),Darwin)
-! # OPTCCFLAGS += -O3 -DNDEBUG
-! OPTCCFLAGS += -DNDEBUG
- else
- OPTCCFLAGS += -O2 -DNDEBUG
- endif
diff --git a/devel/pwlib152/files/patch-videoio b/devel/pwlib152/files/patch-videoio
deleted file mode 100644
index 74d8a5c43c02..000000000000
--- a/devel/pwlib152/files/patch-videoio
+++ /dev/null
@@ -1,36 +0,0 @@
-*** include/ptlib/unix/ptlib/videoio.h.orig Mon Jan 6 18:41:08 2003
---- include/ptlib/unix/ptlib/videoio.h Tue Dec 2 09:42:10 2003
-***************
-*** 106,112 ****
- #include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
- #endif
-
-! #if defined(P_FREEBSD)
- #include <machine/ioctl_meteor.h>
- #endif
-
---- 106,112 ----
- #include <linux/videodev.h> /* change this to "videodev2.h" for v4l2 */
- #endif
-
-! #if defined(P_FREEBSD) && !defined(NO_VIDEO_CAPTURE)
- #include <machine/ioctl_meteor.h>
- #endif
-
-***************
-*** 186,192 ****
- struct video_mmap frameBuffer[2];
- #endif
-
-! #if defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)
- struct video_capability
- {
- int channels; /* Num channels */
---- 186,192 ----
- struct video_mmap frameBuffer[2];
- #endif
-
-! #if (defined(P_FREEBSD) || defined(P_OPENBSD) || defined(P_NETBSD)) && !defined(NO_VIDEO_CAPTURE)
- struct video_capability
- {
- int channels; /* Num channels */
diff --git a/devel/pwlib152/pkg-descr b/devel/pwlib152/pkg-descr
deleted file mode 100644
index df064540dc9a..000000000000
--- a/devel/pwlib152/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-PWLib is a multi-platform code library that can be used to write
-applications that will compile and run on the BSD Unixes, Windows, Linux
-and a few other Unix variants. It was developed by Equivalence Ltd Pty.
-
-It is used by the OpenH323 library.
-
-NOTE: This port does not install anything.
-The ports which use pwlib all look inside their local
-pwlib port directory for the library and header files
-and are compiled statically.
-
-WWW: http://www.openh323.org/
diff --git a/devel/pwlib152/pkg-plist b/devel/pwlib152/pkg-plist
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/devel/pwlib152/pkg-plist
+++ /dev/null