aboutsummaryrefslogtreecommitdiff
path: root/devel/py-dbus
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-dbus')
-rw-r--r--devel/py-dbus/Makefile10
-rw-r--r--devel/py-dbus/pkg-plist6
2 files changed, 15 insertions, 1 deletions
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
index 8627128433d2..f30236b4392f 100644
--- a/devel/py-dbus/Makefile
+++ b/devel/py-dbus/Makefile
@@ -27,6 +27,14 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR}
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/rst2html) && !defined(NOPORTDOCS)
+PLIST_SUB+= HTML=""
+.else
+PLIST_SUB+= HTML="@comment "
+.endif
+
post-install:
.if defined(NOPORTDOCS)
@${RM} -rf ${DOCSDIR}
@@ -35,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/examples/*.py ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/py-dbus/pkg-plist b/devel/py-dbus/pkg-plist
index d5a7b49bd3d9..1fbc36d3b07b 100644
--- a/devel/py-dbus/pkg-plist
+++ b/devel/py-dbus/pkg-plist
@@ -1,11 +1,17 @@
include/dbus-1.0/dbus/dbus-python.h
libdata/pkgconfig/dbus-python.pc
%%PORTDOCS%%%%DOCSDIR%%/API_CHANGES.txt
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/API_CHANGES.html
%%PORTDOCS%%%%DOCSDIR%%/HACKING.txt
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/HACKING.html
%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/NEWS.html
%%PORTDOCS%%%%DOCSDIR%%/README
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/README.html
%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/TODO.html
%%PORTDOCS%%%%DOCSDIR%%/tutorial.txt
+%%HTML%%%%PORTDOCS%%%%DOCSDIR%%/tutorial.html
%%PORTDOCS%%%%EXAMPLESDIR%%/example-async-client.py
%%PORTDOCS%%%%EXAMPLESDIR%%/example-client.py
%%PORTDOCS%%%%EXAMPLESDIR%%/example-service.py