aboutsummaryrefslogtreecommitdiff
path: root/devel/py-gobject/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-gobject/Makefile')
-rw-r--r--devel/py-gobject/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/py-gobject/Makefile b/devel/py-gobject/Makefile
index 0a6f1c55a573..b7c2855cac04 100644
--- a/devel/py-gobject/Makefile
+++ b/devel/py-gobject/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/py-gobject/Makefile,v 1.29 2009/01/04 22:11:03 marcus Exp $
+# $MCom: ports/devel/py-gobject/Makefile,v 1.35 2009/09/23 21:44:30 kwm Exp $
#
PORTNAME= gobject
-PORTVERSION= 2.16.1
+PORTVERSION= 2.20.0
CATEGORIES= devel python
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/pygobject/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -18,6 +18,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python bindings for GObject
+LIB_DEPENDS= girepository-1.0.0:${PORTSDIR}/devel/gobject-introspection
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack glib20
@@ -27,5 +29,10 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-docs
CONFLICTS= py*-gtk-0*
+PLIST_SUB= PYTHON_VER="${PYTHON_VER}"
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ ${PREFIX}/share/pygobject/2.0/codegen
.include <bsd.port.mk>