aboutsummaryrefslogtreecommitdiff
path: root/devel/py-mx-experimental/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-mx-experimental/Makefile')
-rw-r--r--devel/py-mx-experimental/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/py-mx-experimental/Makefile b/devel/py-mx-experimental/Makefile
new file mode 100644
index 000000000000..9d11f9f7c7c4
--- /dev/null
+++ b/devel/py-mx-experimental/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: py-mx-experimental
+# Date created: Nov 3, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mx-experimental
+PORTVERSION= 0.6.0
+CATEGORIES= devel python
+MASTER_SITES= http://www.lemburg.com/files/python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= egenix-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PYDISTUTILS}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/BeeBase/BeeBase.py:${PORTSDIR}/lang/py-mx-base
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>