aboutsummaryrefslogtreecommitdiff
path: root/devel/py-qt4-core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-qt4-core/Makefile')
-rw-r--r--devel/py-qt4-core/Makefile32
1 files changed, 14 insertions, 18 deletions
diff --git a/devel/py-qt4-core/Makefile b/devel/py-qt4-core/Makefile
index 1560478621f1..6ddf18f92472 100644
--- a/devel/py-qt4-core/Makefile
+++ b/devel/py-qt4-core/Makefile
@@ -6,15 +6,13 @@
PORTNAME= core
PORTVERSION= ${PYQT4_VERSION}
-PORTREVISION= 2
PORTEPOCH= 1
-
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITES_PYQT4}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
DISTNAME= ${PYQT4_DISTNAME}
-MAINTAINER= ${PYQT_MAINTAINER}
+MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtCore module
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
@@ -23,7 +21,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
USE_QT_VER= 4
-QT_COMPONENTS= corelib qmake
+QT_COMPONENTS= corelib qmake_build
OPTIONS= API "Install QtCore API for QScintilla2" on \
DEBUG "Enable debugging in generated code" off \
@@ -32,11 +30,14 @@ OPTIONS= API "Install QtCore API for QScintilla2" on \
OPTIONSFILE= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
SIPDIR= ${PREFIX}/share/py-sip
+QSCIDIR= ${PREFIX}/share/qt4/qsci
CONFIGURE_ENV+= PYQT4_COMPONENT="${PORTNAME}"
ARGS= -b ${PREFIX}/bin\
- -d ${PYTHON_SITELIBDIR}\
- -q ${QT_PREFIX}/bin/qmake-qt4\
- --confirm-license
+ -d ${PYTHONPREFIX_SITELIBDIR}\
+ -p ${PREFIX}/${QT_PLUGINDIR_REL}\
+ -q ${QMAKE}\
+ --confirm-license\
+ --enable QtCore
.include "../py-sip/files/bsd.pyqt.mk"
.include <bsd.port.pre.mk>
@@ -47,26 +48,21 @@ ARGS+= --debug
.if defined(WITHOUT_API)
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
-PLIST_SUB+= APIFILE="@comment "
.else
-LIB_DEPENDS+= qscintilla2.3:${PORTSDIR}/devel/qscintilla2
-ARGS+= --qsci-api
+LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
-PLIST_SUB+= APIFILE="share/qt4/qsci/api/python/QtCore.api"
.endif
.if defined(WITHOUT_SIPFILES)
ARGS+= --no-sip-files
-PLIST_SUB+= SIPFILES="@comment "
-PLIST_SUB+= SIPDIR="@comment "
+PLIST_SUB+= SIP="@comment "
.else
ARGS+= --sipdir ${SIPDIR}
-PLIST_SUB+= SIPFILES=""
-PLIST_SUB+= SIPDIR="share/py-sip"
+PLIST_SUB+= SIP=""
.endif
.if defined(WITH_TRACING)
ARGS+= --trace
.endif
-ARGS+= --enable QtCore
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
@@ -80,8 +76,8 @@ post-configure:
${WRKSRC}/QtCore/Makefile
post-install:
- ${INSTALL_DATA} ${FILESDIR}/Qt.py ${PYTHON_SITELIBDIR}/PyQt4 &&\
- cd ${PYTHON_SITELIBDIR}/PyQt4 &&\
+ ${INSTALL_DATA} ${FILESDIR}/Qt.py ${PYTHONPREFIX_SITELIBDIR}/PyQt4 &&\
+ cd ${PYTHONPREFIX_SITELIBDIR}/PyQt4 &&\
${PYTHON_CMD} ${PYTHON_LIBDIR}/py_compile.py\
`ls *.py */*.py */*/*.py` &&\
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/py_compile.py\