aboutsummaryrefslogtreecommitdiff
path: root/devel/py-simplejson/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-simplejson/Makefile')
-rw-r--r--devel/py-simplejson/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/py-simplejson/Makefile b/devel/py-simplejson/Makefile
index 5b5a8dc6ea67..29fbd2f38a81 100644
--- a/devel/py-simplejson/Makefile
+++ b/devel/py-simplejson/Makefile
@@ -6,10 +6,14 @@
#
PORTNAME= simplejson
-PORTVERSION= 1.9.2
+PORTVERSION= 1.9.3
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= CHEESESHOP:source1 \
+ http://peak.telecommunity.com/dist/:source2
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:source1 \
+ ez_setup.py:source2
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= python@FreeBSD.org
COMMENT= Simplejson is a simple, fast, extensible JSON encoder/decoder
@@ -18,13 +22,13 @@ USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYEASYINSTALL_ARCHDEP= yes
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-PORTDOCS= *
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
.endif
+post-extract:
+ ${CP} ${DISTDIR}/ez_setup.py ${WRKSRC}
+
.include <bsd.port.mk>