aboutsummaryrefslogtreecommitdiff
path: root/devel/py-urlimport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-urlimport/Makefile')
-rw-r--r--devel/py-urlimport/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/py-urlimport/Makefile b/devel/py-urlimport/Makefile
new file mode 100644
index 000000000000..8b0ef7e06f77
--- /dev/null
+++ b/devel/py-urlimport/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-urlimport
+# Date created: 2006-12-31
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= urlimport
+PORTVERSION= 0.42b
+CATEGORIES= devel python
+MASTER_SITES= http://www.cs.nctu.edu.tw/~lwhsu/ports/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+EXTRACT_SUFX= .py
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Python script for importing modules/packages over the net
+
+NO_WRKSUBDIR= yes
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/urlimport.py \
+ %%PYTHON_SITELIBDIR%%/urlimport.pyc \
+ %%PYTHON_SITELIBDIR%%/urlimport.pyo
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PORTNAME}.py
+ ${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|g' ${FILESDIR}/setup.py \
+ > ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>