aboutsummaryrefslogtreecommitdiff
path: root/devel/pymacs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pymacs/Makefile')
-rw-r--r--devel/pymacs/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/pymacs/Makefile b/devel/pymacs/Makefile
index aa8c96e51073..2a566ff901ab 100644
--- a/devel/pymacs/Makefile
+++ b/devel/pymacs/Makefile
@@ -25,6 +25,12 @@ USE_EMACS= yes
EMACS_PORT_NAME=xemacs21
.endif
+post-patch:
+.for f in __init__.py pymacs.py
+ ${REINPLACE_CMD} -e 's,# Copyright,# coding:latin1 Copyright,g' \
+ ${WRKSRC}/Pymacs/$f
+.endfor
+
# Install the emacs side of things
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/pymacs.el ${PREFIX}/${EMACS_SITE_LISPDIR}