aboutsummaryrefslogtreecommitdiff
path: root/devel/pythontidy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pythontidy/Makefile')
-rw-r--r--devel/pythontidy/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/pythontidy/Makefile b/devel/pythontidy/Makefile
new file mode 100644
index 000000000000..3dececdf81e2
--- /dev/null
+++ b/devel/pythontidy/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pythontidy
+# Date created: Jan. 16 ,2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pythontidy
+PORTVERSION= 1.10
+CATEGORIES= devel python
+MASTER_SITES= http://www.lacusveris.com/PythonTidy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PythonTidy-${PORTVERSION}.python
+EXTRACT_SUFX= #
+DIST_SUBDIR= python
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Cleans up, regularizes, and reformats the text of Python scripts
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/pythontidy
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKDIR}
+
+do-patch:
+ ${REINPLACE_CMD} -e s,/usr/bin/python,${PYTHON_CMD}, ${WRKDIR}/${DISTFILES}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTFILES} ${TARGETDIR}/bin/pythontidy
+
+.include <bsd.port.mk>