aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-corelib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt4-corelib/Makefile')
-rw-r--r--devel/qt4-corelib/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index 657e94bd2541..600ffd7198f2 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -21,7 +21,7 @@ COMMENT= Qt core library
LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc
+QT_COMPONENTS= qmake_build moc_build
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -47,8 +47,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
PATCH_WRKSRC=${CONFIGURE_WRKSRC}
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -60,16 +58,14 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.if !defined(PKGNAMESUFFIX)
post-install:
${MKDIR} ${PREFIX}/lib/plugins
${TOUCH} ${PREFIX}/lib/plugins/.keep_me
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>