aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-designer
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt4-designer')
-rw-r--r--devel/qt4-designer/Makefile80
-rw-r--r--devel/qt4-designer/distinfo3
-rw-r--r--devel/qt4-designer/pkg-descr12
-rw-r--r--devel/qt4-designer/pkg-plist94
4 files changed, 189 insertions, 0 deletions
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
new file mode 100644
index 000000000000..13216518044d
--- /dev/null
+++ b/devel/qt4-designer/Makefile
@@ -0,0 +1,80 @@
+### -*-mode: makefile-*-
+# New ports collection makefile for: qt40
+# Date created: Wed Jun 29 11:49:42 CEST 2005
+# Whom: lofi@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= designer
+PORTVERSION= 4.2.2
+CATEGORIES?= x11-toolkits ipv6
+MASTER_SITES= ${MASTER_SITE_QT}
+PKGNAMEPREFIX= qt4-
+DISTNAME= qt-x11-opensource-src-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt ui editor
+
+BUILD_DEPENDS= moc4:${PORTSDIR}/devel/qt4-moc \
+ qmake-qt4:${PORTSDIR}/devel/qmake4 \
+ rcc:${PORTSDIR}/devel/qt4-rcc \
+ uic4:${PORTSDIR}/devel/qt4-uic
+LIB_DEPENDS= QtAssistantClient:${PORTSDIR}/devel/qt4-libqtassistantclient \
+ Qt3Support:${PORTSDIR}/devel/qt4-qt3support \
+ QtCore:${PORTSDIR}/devel/qt4-corelib \
+ QtGui:${PORTSDIR}/x11-toolkits/qt4-gui \
+ QtNetwork:${PORTSDIR}/net/qt4-network \
+ QtSql:${PORTSDIR}/databases/qt4-sql \
+ QtXml:${PORTSDIR}/textproc/qt4-xml
+
+CONFLICTS= linguist-0.* qt-2.* qt-3.0.* \
+ qt-3.1.* qt-3.2.* qt-designer-2.* xfmail-1.5.[0-5] \
+ xfmail-1.5.5_[1-2]
+
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+NO_FILTER_SHLIBS=yes
+
+CONFIGURE_ARGS= -fast -no-exceptions \
+ -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
+ -qt-gif -release -system-libjpeg -system-libpng \
+ -system-zlib -no-nas-sound -prefix ${PREFIX} \
+ -plugindir ${PREFIX}/lib/plugins -bindir ${PREFIX}/bin \
+ -confirm-license
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+ PATH=${WRKSRC}/bin:$$PATH
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
+ --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
+ --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
+ --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/sql' \
+ --exclude '${DISTNAME}/src/tools/moc' --exclude '${DISTNAME}/src/tools/rcc' \
+ --exclude '${DISTNAME}/src/tools/uic3' \
+ --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
+ --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+WRKSRC= ${WRKDIR}/${DISTNAME}/tools/${PORTNAME}
+CONFIGURE_WRKSRC=${WRKSRC}/../../
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/bin|g' \
+ ${WRKSRC}/src/designer/${PORTNAME}.pro
+ ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib/plugins|g' \
+ ${WRKSRC}/src/plugins/plugins.pri
+ ${REINPLACE_CMD} -e \
+ 's|designer_headers.path.*|designer_headers.path=${PREFIX}/include/QtDesigner|g' \
+ -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
+ ${WRKSRC}/src/lib/lib.pro ${WRKSRC}/src/components/lib/lib.pro
+ ${MKDIR} ${WRKSRC}/../../mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/uic4 ${WRKSRC}/../../bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
+
+.include <bsd.port.post.mk>
diff --git a/devel/qt4-designer/distinfo b/devel/qt4-designer/distinfo
new file mode 100644
index 000000000000..5f51cf7b1256
--- /dev/null
+++ b/devel/qt4-designer/distinfo
@@ -0,0 +1,3 @@
+MD5 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 19f6374fe7924e33775cb87ee02669cb
+SHA256 (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = e790d227fa7958f2b0c0b0facd8ca880190121ed2b9c99ca70643baf7a0cd24c
+SIZE (KDE/qt-x11-opensource-src-4.2.2.tar.gz) = 37636491
diff --git a/devel/qt4-designer/pkg-descr b/devel/qt4-designer/pkg-descr
new file mode 100644
index 000000000000..efc79b9aaf24
--- /dev/null
+++ b/devel/qt4-designer/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://www.trolltech.com/products/qt/index.html
diff --git a/devel/qt4-designer/pkg-plist b/devel/qt4-designer/pkg-plist
new file mode 100644
index 000000000000..6394ea063adc
--- /dev/null
+++ b/devel/qt4-designer/pkg-plist
@@ -0,0 +1,94 @@
+bin/designer
+bin/designer.debug
+include/QtDesigner/QAbstractExtensionFactory
+include/QtDesigner/QAbstractExtensionManager
+include/QtDesigner/QAbstractFormBuilder
+include/QtDesigner/QDesignerActionEditorInterface
+include/QtDesigner/QDesignerBrushManagerInterface
+include/QtDesigner/QDesignerComponents
+include/QtDesigner/QDesignerContainerExtension
+include/QtDesigner/QDesignerCustomWidgetCollectionInterface
+include/QtDesigner/QDesignerCustomWidgetInterface
+include/QtDesigner/QDesignerDnDItemInterface
+include/QtDesigner/QDesignerExportWidget
+include/QtDesigner/QDesignerExtraInfoExtension
+include/QtDesigner/QDesignerFormEditorInterface
+include/QtDesigner/QDesignerFormEditorPluginInterface
+include/QtDesigner/QDesignerFormWindowCursorInterface
+include/QtDesigner/QDesignerFormWindowInterface
+include/QtDesigner/QDesignerFormWindowManagerInterface
+include/QtDesigner/QDesignerFormWindowToolInterface
+include/QtDesigner/QDesignerIconCacheInterface
+include/QtDesigner/QDesignerLanguageExtension
+include/QtDesigner/QDesignerLayoutDecorationExtension
+include/QtDesigner/QDesignerMemberSheetExtension
+include/QtDesigner/QDesignerMetaDataBaseInterface
+include/QtDesigner/QDesignerMetaDataBaseItemInterface
+include/QtDesigner/QDesignerObjectInspectorInterface
+include/QtDesigner/QDesignerPropertyEditorInterface
+include/QtDesigner/QDesignerPropertySheetExtension
+include/QtDesigner/QDesignerTaskMenuExtension
+include/QtDesigner/QDesignerWidgetBoxInterface
+include/QtDesigner/QDesignerWidgetDataBaseInterface
+include/QtDesigner/QDesignerWidgetDataBaseItemInterface
+include/QtDesigner/QDesignerWidgetFactoryInterface
+include/QtDesigner/QExtensionFactory
+include/QtDesigner/QExtensionManager
+include/QtDesigner/QFormBuilder
+include/QtDesigner/QtDesigner
+include/QtDesigner/abstractactioneditor.h
+include/QtDesigner/abstractbrushmanager.h
+include/QtDesigner/abstractdnditem.h
+include/QtDesigner/abstractformbuilder.h
+include/QtDesigner/abstractformeditor.h
+include/QtDesigner/abstractformeditorplugin.h
+include/QtDesigner/abstractformwindow.h
+include/QtDesigner/abstractformwindowcursor.h
+include/QtDesigner/abstractformwindowmanager.h
+include/QtDesigner/abstractformwindowtool.h
+include/QtDesigner/abstracticoncache.h
+include/QtDesigner/abstractlanguage.h
+include/QtDesigner/abstractmetadatabase.h
+include/QtDesigner/abstractobjectinspector.h
+include/QtDesigner/abstractpropertyeditor.h
+include/QtDesigner/abstractwidgetbox.h
+include/QtDesigner/abstractwidgetdatabase.h
+include/QtDesigner/abstractwidgetfactory.h
+include/QtDesigner/container.h
+include/QtDesigner/customwidget.h
+include/QtDesigner/default_extensionfactory.h
+include/QtDesigner/extension.h
+include/QtDesigner/extension_global.h
+include/QtDesigner/extrainfo.h
+include/QtDesigner/formbuilder.h
+include/QtDesigner/layoutdecoration.h
+include/QtDesigner/membersheet.h
+include/QtDesigner/propertysheet.h
+include/QtDesigner/qdesigner_components.h
+include/QtDesigner/qdesigner_components_global.h
+include/QtDesigner/qdesignerexportwidget.h
+include/QtDesigner/qextensionmanager.h
+include/QtDesigner/sdk_global.h
+include/QtDesigner/taskmenu.h
+include/QtDesigner/uilib_global.h
+include/QtUiTools/QUiLoader
+include/QtUiTools/QtUiTools
+include/QtUiTools/quiloader.h
+lib/libQtDesigner.prl
+lib/libQtDesigner.so
+lib/libQtDesigner.so.4
+lib/libQtDesigner.so.4.2
+lib/libQtDesigner.so.4.2.2
+lib/libQtDesigner.so.4.2.2.debug
+lib/libQtDesignerComponents.prl
+lib/libQtDesignerComponents.so
+lib/libQtDesignerComponents.so.4
+lib/libQtDesignerComponents.so.4.2
+lib/libQtDesignerComponents.so.4.2.2
+lib/libQtDesignerComponents.so.4.2.2.debug
+lib/libQtUiTools.a
+lib/libQtUiTools.prl
+lib/plugins/libqt3supportwidgets.so
+lib/plugins/libqt3supportwidgets.so.debug
+@dirrm include/QtUiTools
+@dirrm include/QtDesigner