aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-qt3support/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt4-qt3support/Makefile')
-rw-r--r--devel/qt4-qt3support/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/devel/qt4-qt3support/Makefile b/devel/qt4-qt3support/Makefile
index 0c8dc2617a3b..a931e8221b1c 100644
--- a/devel/qt4-qt3support/Makefile
+++ b/devel/qt4-qt3support/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt3 compatibility library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui network sql xml
+QT_COMPONENTS= qmake_build moc_build corelib gui network sql xml
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -45,8 +45,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
PATCH_WRKSRC=${CONFIGURE_WRKSRC}
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -64,4 +62,4 @@ post-configure:
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>