aboutsummaryrefslogtreecommitdiff
path: root/devel/re2c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/re2c/Makefile')
-rw-r--r--devel/re2c/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/devel/re2c/Makefile b/devel/re2c/Makefile
index 8434fcfc225d..e3cbe916622b 100644
--- a/devel/re2c/Makefile
+++ b/devel/re2c/Makefile
@@ -6,21 +6,29 @@
#
PORTNAME= re2c
-PORTVERSION= 0.5
+PORTVERSION= 0.9.1
CATEGORIES= devel
-MASTER_SITES= ftp://csg.uwaterloo.ca/pub/peter/ \
- ftp://ftp.uni-trier.de/pub/unix/compiler-toolkit/re2c/ \
- ftp://ftp.tut.ac.jp/.h3/UNIX/lib/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+MASTER_SITES= http://www.tildeslash.org/re2c/ \
+ http://freesoftware.missouri.edu/pub/NetSW/SoftEng/CompilerConstruct/re2c/ \
+ http://www.tobez.org/download/port-mirrors/devel/re2c/
MAINTAINER= eivind@FreeBSD.org
+USE_GMAKE= yes
+
MAN1= re2c.1
ALL_TARGET= default
+pre-patch:
+ @${PERL} -pi -e 's|^CFLAGS.*$$|CFLAGS+=-Wall -I. -Wno-unused -Wno-parentheses|' ${WRKSRC}/Makefile
+ @${PERL} -pi -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/parser.cc ${WRKSRC}/parser.y
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/re2c ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/re2c.1 ${PREFIX}/man/man1
+ ${MKDIR} ${PREFIX}/share/doc/re2c
+ ${INSTALL_DATA} ${WRKSRC}/doc/loplas.ps.gz ${WRKSRC}/doc/sample.bib \
+ ${PREFIX}/share/doc/re2c
.include <bsd.port.mk>