aboutsummaryrefslogtreecommitdiff
path: root/devel/readline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/readline/Makefile')
-rw-r--r--devel/readline/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/readline/Makefile b/devel/readline/Makefile
index 44a8b4277b07..30f045f885db 100644
--- a/devel/readline/Makefile
+++ b/devel/readline/Makefile
@@ -20,8 +20,14 @@ COMMENT= A library for editing command lines as they are typed
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
INFO= readline rluserman history
MAN3= readline.3 history.3
+pre-configure:
+.if !defined(WITHOUT_TERMCAP)
+ ${REINPLACE_CMD} "s/SHOBJ_LDFLAGS =/SHOBJ_LDFLAGS = -ltermcap/" ${WRKSRC}/shlib/Makefile.in
+.endif
+
.include <bsd.port.mk>