aboutsummaryrefslogtreecommitdiff
path: root/devel/regexx/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/regexx/files')
-rw-r--r--devel/regexx/files/patch-configure.in15
-rw-r--r--devel/regexx/files/patch-src::Makefile.am10
2 files changed, 12 insertions, 13 deletions
diff --git a/devel/regexx/files/patch-configure.in b/devel/regexx/files/patch-configure.in
index d52b5cb7836c..50db322ccd9f 100644
--- a/devel/regexx/files/patch-configure.in
+++ b/devel/regexx/files/patch-configure.in
@@ -1,11 +1,10 @@
---- configure.in.orig Fri Mar 2 01:11:35 2001
-+++ configure.in Fri Mar 2 01:11:44 2001
-@@ -24,8 +24,3 @@
+--- configure.in.orig Thu Mar 15 14:20:50 2001
++++ configure.in Thu Mar 15 14:21:01 2001
+@@ -23,7 +23,5 @@
+
dnl Checks for library functions.
- AC_OUTPUT([Makefile src/Makefile examples/Makefile regexx.spec])
--
--cd pcre
--./configure
--cd ..
+-AC_CONFIG_SUBDIRS(pcre)
-
+ AC_OUTPUT([Makefile src/Makefile examples/Makefile regexx.spec])
+
diff --git a/devel/regexx/files/patch-src::Makefile.am b/devel/regexx/files/patch-src::Makefile.am
index 9cdd575623e0..04dc86120e33 100644
--- a/devel/regexx/files/patch-src::Makefile.am
+++ b/devel/regexx/files/patch-src::Makefile.am
@@ -1,11 +1,11 @@
---- src/Makefile.am.orig Tue Aug 22 21:54:30 2000
-+++ src/Makefile.am Wed Mar 7 19:25:48 2001
+--- src/Makefile.am.orig Thu Mar 15 14:40:46 2001
++++ src/Makefile.am Tue Mar 13 22:42:21 2001
@@ -5,6 +5,7 @@
##
-+INCLUDES=-I/usr/local/include
++INCLUDES=`pcre-config --cflags`
lib_LTLIBRARIES = libregexx.la
libregexx_la_SOURCES = regexx.cc regexx.hh split.cc split.hh
--libregexx_la_LDFLAGS = -version-info 1:1:1 ../pcre/maketables.lo ../pcre/get.lo ../pcre/study.lo ../pcre/pcre.lo
-+libregexx_la_LDFLAGS = -version-info 1:1:1 -lpcre -L/usr/local/lib
+-libregexx_la_LDFLAGS = -version-info 2:0:1 ../pcre/maketables.lo ../pcre/get.lo ../pcre/study.lo ../pcre/pcre.lo
++libregexx_la_LDFLAGS = -version-info 2:0:1 `pcre-config --libs`
include_HEADERS = regexx.hh split.hh