aboutsummaryrefslogtreecommitdiff
path: root/devel/relx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/relx/Makefile')
-rw-r--r--devel/relx/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/relx/Makefile b/devel/relx/Makefile
index 6c288eaabf10..ab55500a540d 100644
--- a/devel/relx/Makefile
+++ b/devel/relx/Makefile
@@ -39,7 +39,7 @@ REBAR_DEPS= bbmustache-1.0.4 \
DISTFILES+= ${_dep}.tar:hex
.endfor
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
# convenience target to rebuild the relx cache file
build-cache:
@@ -80,11 +80,12 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/_build/default/lib/relx/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
cd ${WRKSRC}/priv && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/priv
${INSTALL_SCRIPT} ${WRKSRC}/_build/default/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>