aboutsummaryrefslogtreecommitdiff
path: root/devel/roboctl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/roboctl/Makefile')
-rw-r--r--devel/roboctl/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/devel/roboctl/Makefile b/devel/roboctl/Makefile
index 920586b2b8b0..d793c423b594 100644
--- a/devel/roboctl/Makefile
+++ b/devel/roboctl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= roboctl
-PORTVERSION= 0.3.5
+PORTVERSION= 0.3.6
CATEGORIES= devel
MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
http://jbacon.dyndns.org/~bacon/Ports/distfiles/
@@ -16,6 +16,8 @@ COMMENT= API and tools for communicating with Lego and Vex robots
BUILD_DEPENDS= ${LOCALBASE}/lib/libgamepad.a:${PORTSDIR}/devel/libgamepad
+MAKE_ENV= EXTRALIBS=-lbluetooth
+
OPTIONS= CUTECOM "Install cutecom for Vex debugging" On
MAN1= legoctl.1 vexctl.1 nxtremote.1
@@ -31,11 +33,8 @@ LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
RUN_DEPENDS+= cutecom:${PORTSDIR}/comms/cutecom
.endif
-post-patch:
-.if ${OSVERSION} >= 800069
- @${REINPLACE_CMD} -E -e 's,/usr/local/include/usb.h,/usr/include/usb.h,g' \
- ${WRKSRC}/Libs/C/Makefile.depend
-.endif
+pre-build:
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} depend)
post-install:
(cd ${WRKSRC}/Commands/NXTRemote; ${MAKE})