aboutsummaryrefslogtreecommitdiff
path: root/devel/root/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/root/files')
-rw-r--r--devel/root/files/patch-base::src::TMath.cxx19
-rw-r--r--devel/root/files/patch-cint::lib::pthread::setup19
-rw-r--r--devel/root/files/patch-config::root-config.in39
-rw-r--r--devel/root/files/patch-configure19
-rw-r--r--devel/root/files/patch-test::Makefile.arch10
-rw-r--r--devel/root/files/patch-x11ttf::Module.mk19
-rw-r--r--devel/root/files/patch-xml::Module.mk4
-rw-r--r--devel/root/files/rootlibs.sh.in28
8 files changed, 127 insertions, 30 deletions
diff --git a/devel/root/files/patch-base::src::TMath.cxx b/devel/root/files/patch-base::src::TMath.cxx
new file mode 100644
index 000000000000..49ca338514ac
--- /dev/null
+++ b/devel/root/files/patch-base::src::TMath.cxx
@@ -0,0 +1,19 @@
+*** base/src/TMath.cxx.orig Mon Jun 13 15:31:57 2005
+--- base/src/TMath.cxx Sat Jul 9 19:38:38 2005
+***************
+*** 31,37 ****
+ const Int_t kWorkMax = 100;
+
+ // Without this macro the THtml doc for TMath can not be generated
+! #if !defined(R__ALPHA) && !defined(R__SOLARIS) && !defined(R__ACC)
+ NamespaceImp(TMath)
+ #endif
+
+--- 31,37 ----
+ const Int_t kWorkMax = 100;
+
+ // Without this macro the THtml doc for TMath can not be generated
+! #if !defined(R__ALPHA) && !defined(R__SOLARIS) && !defined(R__ACC) && !defined(R__FBSD)
+ NamespaceImp(TMath)
+ #endif
+
diff --git a/devel/root/files/patch-cint::lib::pthread::setup b/devel/root/files/patch-cint::lib::pthread::setup
new file mode 100644
index 000000000000..4a2b64fcfdf4
--- /dev/null
+++ b/devel/root/files/patch-cint::lib::pthread::setup
@@ -0,0 +1,19 @@
+*** cint/lib/pthread/setup.orig Mon Feb 28 18:28:12 2005
+--- cint/lib/pthread/setup Sat Jul 9 19:39:34 2005
+***************
+*** 5,11 ****
+ case $os in
+ FreeBSD)
+ # Use following line for FreeBSD
+! makecint -mk Makefile -dl pthread.dll -H pthd.h -D_THREAD_SAFE -D_POSIX_C_SOURCE=199506L -l -pthread -cint -Z0
+ ;;
+ OpenBSD)
+ # Use following line for OpenBSD
+--- 5,11 ----
+ case $os in
+ FreeBSD)
+ # Use following line for FreeBSD
+! makecint -mk Makefile -dl pthread.dll -H pthd.h -D_THREAD_SAFE -D_POSIX_C_SOURCE=199506L -l $PTHREAD_LIBS -cint -Z0
+ ;;
+ OpenBSD)
+ # Use following line for OpenBSD
diff --git a/devel/root/files/patch-config::root-config.in b/devel/root/files/patch-config::root-config.in
index ad70021bb492..2566df843476 100644
--- a/devel/root/files/patch-config::root-config.in
+++ b/devel/root/files/patch-config::root-config.in
@@ -1,28 +1,21 @@
-*** config/root-config.in.orig Mon Jul 5 16:49:16 2004
---- config/root-config.in Mon Jul 5 16:51:05 2004
+*** config/root-config.in.orig Fri Jun 10 20:12:55 2005
+--- config/root-config.in Sat Jul 9 19:46:11 2005
***************
-*** 245,253 ****
- auxlibs="-lm -lg++"
+*** 260,267 ****
;;
- freebsd4)
-! # FreeBSD with glibc
- auxcflags=
- auxlibs="-lm -lstdc++"
+ freebsd5)
+ # FreeBSD 5 with glibc
+! auxcflags=
+! auxlibs="-lm -lstdc++"
;;
- macosx)
- # MacOS X with gcc (GNU cc v3.1) and possible fink (fink.sf.net)
---- 245,258 ----
- auxlibs="-lm -lg++"
+ openbsd)
+ # OpenBSD with libc
+--- 260,267 ----
;;
- freebsd4)
-! # FreeBSD 4.x with glibc
- auxcflags=
- auxlibs="-lm -lstdc++"
-+ ;;
-+ freebsd5)
-+ # FreeBSD 5.x with glibc
-+ auxcflags="PTHREAD-CFLAGS"
-+ auxlibs="PTHREAD-LIBS -lm -lstdc++"
+ freebsd5)
+ # FreeBSD 5 with glibc
+! auxcflags="PTHREAD-CFLAGS"
+! auxlibs="PTHREAD-LIBS -lm -lstdc++"
;;
- macosx)
- # MacOS X with gcc (GNU cc v3.1) and possible fink (fink.sf.net)
+ openbsd)
+ # OpenBSD with libc
diff --git a/devel/root/files/patch-configure b/devel/root/files/patch-configure
new file mode 100644
index 000000000000..098a9ccfc5d5
--- /dev/null
+++ b/devel/root/files/patch-configure
@@ -0,0 +1,19 @@
+*** configure.orig Sun Jul 10 14:45:42 2005
+--- configure Sun Jul 10 14:46:05 2005
+***************
+*** 1837,1843 ****
+ test "x$enable_shared" = "xno" ; then
+ check_library_options="libruby-static libruby1.8-static"
+ else
+! check_library_options="libruby libruby1.8"
+ fi
+ check_library "$check_library_options" \
+ "$enable_shared" "$rubylibdir" $RUBYDIR $RUBYDIR/lib \
+--- 1837,1843 ----
+ test "x$enable_shared" = "xno" ; then
+ check_library_options="libruby-static libruby1.8-static"
+ else
+! check_library_options="libruby libruby1.8 libruby18"
+ fi
+ check_library "$check_library_options" \
+ "$enable_shared" "$rubylibdir" $RUBYDIR $RUBYDIR/lib \
diff --git a/devel/root/files/patch-test::Makefile.arch b/devel/root/files/patch-test::Makefile.arch
index e144e7e95b8a..6553b28a4761 100644
--- a/devel/root/files/patch-test::Makefile.arch
+++ b/devel/root/files/patch-test::Makefile.arch
@@ -1,9 +1,9 @@
-*** test/Makefile.arch.orig Tue Jun 15 20:02:44 2004
---- test/Makefile.arch Wed Jun 16 10:05:39 2004
+*** test/Makefile.arch.orig Fri Jun 10 20:12:55 2005
+--- test/Makefile.arch Sat Jul 9 19:49:07 2005
***************
*** 9,15 ****
ARCH := $(shell root-config --arch)
- PLATFORM = $(ARCH)
+ PLATFORM := $(shell root-config --platform)
- CXX =
ObjSuf = o
@@ -11,7 +11,7 @@
ExeSuf =
--- 9,14 ----
***************
-*** 426,435 ****
+*** 406,415 ****
ifeq ($(ARCH),freebsd4)
# FreeBSD with glibc
@@ -22,7 +22,7 @@
SOFLAGS = -shared -Wl,-x
endif
---- 425,439 ----
+--- 405,419 ----
ifeq ($(ARCH),freebsd4)
# FreeBSD with glibc
diff --git a/devel/root/files/patch-x11ttf::Module.mk b/devel/root/files/patch-x11ttf::Module.mk
new file mode 100644
index 000000000000..9793063f2245
--- /dev/null
+++ b/devel/root/files/patch-x11ttf::Module.mk
@@ -0,0 +1,19 @@
+*** x11ttf/Module.mk.orig Sun Jul 10 14:47:12 2005
+--- x11ttf/Module.mk Sun Jul 10 14:47:31 2005
+***************
+*** 40,46 ****
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libGX11TTF.$(SOEXT) $@ \
+ "$(X11TTFO) $(X11TTFDO)" \
+! "$(FREETYPELDLFAGS) $(FREETYPELIB) $(X11TTFLIBEXTRA) $(XLIBS)"
+
+ $(X11TTFDS): $(X11TTFH) $(X11TTFL) $(ROOTCINTTMP)
+ @echo "Generating dictionary $@..."
+--- 40,46 ----
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libGX11TTF.$(SOEXT) $@ \
+ "$(X11TTFO) $(X11TTFDO)" \
+! "$(FREETYPELDFLAGS) $(FREETYPELIB) $(X11TTFLIBEXTRA) $(XLIBS)"
+
+ $(X11TTFDS): $(X11TTFH) $(X11TTFL) $(ROOTCINTTMP)
+ @echo "Generating dictionary $@..."
diff --git a/devel/root/files/patch-xml::Module.mk b/devel/root/files/patch-xml::Module.mk
index 1a7691353b78..7170da641f99 100644
--- a/devel/root/files/patch-xml::Module.mk
+++ b/devel/root/files/patch-xml::Module.mk
@@ -1,5 +1,5 @@
---- xml/Module.mk.orig Tue Feb 22 17:32:18 2005
-+++ xml/Module.mk Tue Feb 22 17:32:42 2005
+--- xmlparser/Module.mk.orig Tue Feb 22 17:32:18 2005
++++ xmlparser/Module.mk Tue Feb 22 17:32:42 2005
@@ -67,4 +67,4 @@
##### extra rules ######
diff --git a/devel/root/files/rootlibs.sh.in b/devel/root/files/rootlibs.sh.in
new file mode 100644
index 000000000000..82bff8bb4b5a
--- /dev/null
+++ b/devel/root/files/rootlibs.sh.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+# PROVIDE: rootlibs
+# REQUIRE: ldconfig
+# KEYWORD: Root
+
+. /etc/rc.subr
+
+name=rootlibs
+
+start_cmd=rootlibs_start
+stop_cmd=:
+
+root_libdir="%%PREFIX%%/lib/root"
+cint_libdir="%%PREFIX%%/lib/root/cint"
+
+rootlibs_start()
+{
+ if [ -d "$root_libdir" ]; then
+ /sbin/ldconfig -m "$root_libdir"
+ fi
+ if [ -d "$root_libdir" ]; then
+ /sbin/ldconfig -m "$cint_libdir"
+ fi
+}
+
+load_rc_config $name
+run_rc_command "$1"