aboutsummaryrefslogtreecommitdiff
path: root/devel/root/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/root/files')
-rw-r--r--devel/root/files/patch-config::Makefile.freebsd455
-rw-r--r--devel/root/files/patch-configure11
-rw-r--r--devel/root/files/patch-test::Makefile.arch25
3 files changed, 91 insertions, 0 deletions
diff --git a/devel/root/files/patch-config::Makefile.freebsd4 b/devel/root/files/patch-config::Makefile.freebsd4
new file mode 100644
index 000000000000..ff8c7a896a1a
--- /dev/null
+++ b/devel/root/files/patch-config::Makefile.freebsd4
@@ -0,0 +1,55 @@
+--- config/Makefile.freebsd4.orig Mon Feb 16 11:12:43 2004
++++ config/Makefile.freebsd4 Sat Apr 17 00:35:00 2004
+@@ -5,7 +5,7 @@
+ PLATFORM = fbsd
+
+ DEBUGFLAGS = -g
+-OPTFLAGS = -O
++#OPTFLAGS = -O
+ ifeq (debug,$(findstring debug,$(ROOTBUILD)))
+ OPT = $(DEBUGFLAGS)
+ NOOPT =
+@@ -15,10 +15,10 @@
+ endif
+
+ # Compiler:
+-CXX = g++
+-CC = gcc
+-CXXFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CXXFLAGS)
+-CFLAGS = -pipe -W -Wall -fPIC -I/usr/X11R6/include $(EXTRA_CFLAGS)
++#CXX = g++
++#CC = gcc
++CXXFLAGS += -W -Wall -fPIC -I$(X11BASE)/include $(EXTRA_CXXFLAGS)
++CFLAGS += -W -Wall -fPIC -I$(X11BASE)/include $(EXTRA_CFLAGS)
+ CINTCXXFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP $(EXTRA_CXXFLAGS) \
+ -DG__UNIX -DG__SHAREDLIB -DG__ROOT -DG__REDIRECTIO -DG__OSFDLL
+ CINTCFLAGS = -pipe -W -Wall -fPIC -DG__REGEXP -DG__UNIX -DG__SHAREDLIB \
+@@ -26,13 +26,13 @@
+ COMPILER = gnu
+
+ ifeq ($(ENABLETHREAD),yes)
+-CXXFLAGS += -pthread
+-CINTCXXFLAGS += -pthread
++CXXFLAGS += $(PTHREAD_CFLAGS)
++CINTCXXFLAGS += $(PTHREAD_CFLAGS)
+ endif
+
+ # Linker:
+-LD = g++
+-LDFLAGS = $(OPT) $(EXTRA_LDFLAGS)
++LD = $(CXX)
++LDFLAGS += $(OPT) $(EXTRA_LDFLAGS)
+ SOFLAGS = -shared -Wl,-x -Wl,-soname,
+ SOEXT = so
+
+@@ -43,8 +43,8 @@
+ CRYPTLIBS = -lcrypt
+
+ # Fortran:
+-F77 = f77
+-F77FLAGS = $(OPT)
++#F77 = f77
++F77FLAGS += $(OPT)
+ F77LIBS = -lg2c
+
+ # Extras
diff --git a/devel/root/files/patch-configure b/devel/root/files/patch-configure
new file mode 100644
index 000000000000..f68b2459fbf3
--- /dev/null
+++ b/devel/root/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Feb 19 01:11:18 2004
++++ configure Sat Apr 17 13:54:24 2004
+@@ -901,7 +901,7 @@
+ ;;
+ freebsd*)
+ if test "x$enable_thread" = "xyes"; then
+- threadlib="-pthread"
++ threadlib="$PTHREAD_LIBS"
+ threadlibdir=
+ fi
+ ;;
diff --git a/devel/root/files/patch-test::Makefile.arch b/devel/root/files/patch-test::Makefile.arch
new file mode 100644
index 000000000000..fda34e13eef8
--- /dev/null
+++ b/devel/root/files/patch-test::Makefile.arch
@@ -0,0 +1,25 @@
+--- test/Makefile.arch.orig Sat Apr 17 10:25:16 2004
++++ test/Makefile.arch Sat Apr 17 10:41:58 2004
+@@ -9,7 +9,6 @@
+ ARCH := $(shell root-config --arch)
+ PLATFORM = $(ARCH)
+
+-CXX =
+ ObjSuf = o
+ SrcSuf = cxx
+ ExeSuf =
+@@ -426,10 +425,10 @@
+
+ ifeq ($(ARCH),freebsd4)
+ # FreeBSD with glibc
+-CXX = g++
+-CXXFLAGS = -O -pipe -W -Wall -fPIC
+-LD = g++
+-LDFLAGS = -O
++#CXX = g++
++CXXFLAGS += -W -Wall -fPIC
++LD = $(CXX)
++#LDFLAGS = -O
+ SOFLAGS = -shared -Wl,-x
+ endif
+