aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-gems/Makefile.common
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-gems/Makefile.common')
-rw-r--r--devel/ruby-gems/Makefile.common53
1 files changed, 0 insertions, 53 deletions
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
deleted file mode 100644
index a6805e0897a9..000000000000
--- a/devel/ruby-gems/Makefile.common
+++ /dev/null
@@ -1,53 +0,0 @@
-# $FreeBSD$
-# Ruby gem module common settings
-
-
-BUILD_DEPENDS+= ${RUBYGEMBIN}:${PORTSDIR}/devel/ruby-gems
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-PKGNAMEPREFIX= rubygem-
-EXTRACT_SUFX= .gem
-EXTRACT_ONLY=
-DIST_SUBDIR= rubygem
-
-NO_BUILD= yes
-
-REV= 1.8
-GEMS_BASE_DIR= lib/ruby/gems/${REV}
-GEMS_DIR= ${GEMS_BASE_DIR}/gems
-DOC_DIR= ${GEMS_BASE_DIR}/doc
-CACHE_DIR= ${GEMS_BASE_DIR}/cache
-SPEC_DIR= ${GEMS_BASE_DIR}/specifications
-GEM_NAME?= ${PORTNAME}-${PORTVERSION}
-GEM_LIB_DIR= ${GEMS_DIR}/${GEM_NAME}
-GEM_DOC_DIR= ${DOC_DIR}/${GEM_NAME}
-GEM_SPEC= ${SPEC_DIR}/${GEM_NAME}.gemspec
-GEM_CACHE= ${CACHE_DIR}/${GEM_NAME}.gem
-
-PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
- REV="${REV}" \
- GEMS_BASE_DIR="lib/ruby/gems/${REV}" \
- GEMS_DIR="${GEMS_DIR}" \
- DOC_DIR="${DOC_DIR}" \
- CACHE_DIR="${CACHE_DIR}" \
- SPEC_DIR="${SPEC_DIR}" \
- PORT="${PORTNAME}-${PORTVERSION}" \
- GEM_NAME="${GEM_NAME}" \
- GEM_LIB_DIR="${GEM_LIB_DIR}" \
- GEM_DOC_DIR="${GEM_DOC_DIR}" \
- GEM_SPEC="${GEM_SPEC}" \
- GEM_CACHE="${GEM_CACHE}" \
- EXTRACT_SUFX="${EXTRACT_SUFX}"
-
-RUBYGEMBIN= ${LOCALBASE}/bin/gem18
-
-.if defined(DISTFILES)
-GEMFILES= ${DISTFILES:C/:[^:]+$//}
-.else
-GEMFILES= ${DISTNAME}${EXTRACT_SUFX}
-.endif
-
-do-install:
-.for _D in ${GEMFILES}
- ${SETENV} ${GEM_ENV} ${RUBYGEMBIN} install --no-update-sources --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${_D} -- --build-args ${CONFIGURE_ARGS}
-.endfor