aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-ncurses/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-ncurses/Makefile')
-rw-r--r--devel/ruby-ncurses/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/ruby-ncurses/Makefile b/devel/ruby-ncurses/Makefile
new file mode 100644
index 000000000000..6c89b4f10904
--- /dev/null
+++ b/devel/ruby-ncurses/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ncurses-ruby
+# Date created: 7 February 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncurses
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= http://download.berlios.de/ncurses-ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+EXTRACT_SUFX= .tar.bz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_BZIP2= yes
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= README TODO
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/lib
+ ${MV} ${WRKSRC}/ncurses.rb ${WRKSRC}/lib/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>