aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-rbtree/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-rbtree/Makefile')
-rw-r--r--devel/ruby-rbtree/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/ruby-rbtree/Makefile b/devel/ruby-rbtree/Makefile
new file mode 100644
index 000000000000..58fc32227d36
--- /dev/null
+++ b/devel/ruby-rbtree/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Ruby/RBTree
+# Date created: 12 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rbtree
+PORTVERSION= 0.0.2
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.geocities.co.jp/SiliconValley-PaloAlto/3388/rbtree/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+# MIT license
+DOCS= ChangeLog LICENSE README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>